Browse Source

add nextcloud-client, remove gammastep (unused)

main
sseneca 5 months ago
parent
commit
3f3ef15699
  1. 8
      gammastep/PKGBUILD
  2. 101
      nextcloud-client/PKGBUILD

8
gammastep/PKGBUILD

@ -2,7 +2,7 @@
# Maintainer (Arch): David Runge <dvzrv@archlinux.org>
pkgname=gammastep
pkgver=2.0.6
pkgver=2.0.7
pkgrel=1
pkgdesc="Adjust the color temperature of your screen according to your surroundings."
arch=('x86_64')
@ -13,10 +13,10 @@ depends=('glibc' 'hicolor-icon-theme' 'libdrm' 'libx11' 'libxcb'
optdepends=('python-gobject: for gammastep-indicator'
'python-xdg: for gammastep-indicator'
'gtk3: for gammastep-indicator')
makedepends=('intltool' 'python' 'systemd')
makedepends=('glib2' 'intltool' 'python' 'systemd')
source=("https://gitlab.com/chinstrap/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
sha512sums=('3c56c69e8c0f69fbd06100eded10b1cd5378d8bbbe8ab4c5eb2b07c91b0f7a0f8cfd7b0d2ed759add36954d689246dc079692e7d314b700ab3fcdd6bf805e419')
b2sums=('1d7a1098b234f8219a81d3475e7eef992554cef221129ac0a75e23794cb42abf0e79bfe373bffcd432698f80e4fc186bfe5f7ce557100f6359ec11f12656a74c')
sha512sums=('466811636d4c4d5f3fc21272e7ab8c208e2ad8830fbabd48c8d96c2eaa04d07c29da35f409166eaf95acdd0038f926a84d199fabf08df79fb027f45441ef0d08')
b2sums=('2f98399528efc7b37f65f214c07c721d3c3e5d82272feee78d863e8d4bce6c886a6f870383fd05640847fe104a75123036e1a442d915e75d692e8048823db277')
prepare() {
mv -v "$pkgname-v$pkgver" "$pkgname-$pkgver"

101
nextcloud-client/PKGBUILD

@ -0,0 +1,101 @@
# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
# Contributor: Tyler Dence <tyzoid@archlinux32.org>
# Contributor: Konstantin Shalygin <k0ste@k0ste.ru>
pkgbase=nextcloud-client
# Put config files for libcloudproviders integration in a separate package as
# there is no simple way yet to disable it.
# See: https://gitlab.gnome.org/World/libcloudproviders/-/issues/17
pkgname=(nextcloud-client nextcloud-client-cloudproviders)
epoch=2
# Upstream does not provide signed tarballs (yet)
# https://github.com/nextcloud/desktop/issues/1510
pkgver=3.4.2
# `git rev-parse v$pkgver`
_tag=829b4146d413abc0172372e94935d5109089eee5
pkgrel=1
pkgrel+=.parabola1
arch=(x86_64)
url='https://nextcloud.com/'
license=(GPL)
makedepends=(libcloudproviders openssl sqlite
qt5-quickcontrols2 qt5-svg qt5-tools qt5-websockets qtkeychain-qt5
extra-cmake-modules kio
cmocka doxygen git inkscape python-sphinx)
source=("$pkgbase::git+https://github.com/nextcloud/desktop.git?signed#tag=$_tag")
validpgpkeys=(
A26B951528EA1BA1678C7AE5D406C75CEE1A36D6 # one of keys controlled by github.com/camilasan
42E775EAA3E47F9E0D5CDB0E00819E3BF4177B28 # controlled by github.com/misch7
17166A5275C5FA6F1A48FD78074BBBCB8DECC9E2 # https://github.com/er-vin.gpg
01D736173523DFC7A7B55258C2FBEF0E1C7E72D0 # https://github.com/allexzander
267BF70F7905C2723B0243267D0F74F05C22F553 # https://github.com/mgallien
3A877D9A896A057948059DEDAD2C27357B2CB11D # https://github.com/FlexW
)
sha256sums=('SKIP')
pkgver() {
cd $pkgbase
git describe --tags | sed 's/^v//;s/-/+/g'
}
prepare() {
# tmpdir for check()
mkdir tmpdir
}
build() {
cd $pkgbase
# bundled breakpad in libcrashreporter-qt submodule is too old and does not build with glibc >= 2.26
# Upstream fix: https://github.com/google/breakpad/commit/bddcc58860f522a0d4cbaa7e9d04058caee0db9d
cmake -B build -S . \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DWITH_CRASHREPORTER=OFF \
-DUNIT_TESTING=ON \
-DPLUGINDIR=lib/qt/plugins # Fix vfs plugin install dir https://github.com/nextcloud/desktop/issues/3781#issuecomment-918918320
# TODO: fix installation of PDF and HTML documents
# WIP at https://github.com/yan12125/desktop/tree/doc-install-path
make -C build all doc-man
}
check() {
cd $pkgbase/build
# Tests fail if $TMPDIR is too small; specify an alternative for machines
# with a small /tmp partition.
# Use UTC as TestCookies is sensitive to the timezone
# https://github.com/nextcloud/desktop/blob/v3.2.2/test/testcookies.cpp#L24
QT_QPA_PLATFORM=offscreen TMPDIR="$srcdir/tmpdir" TZ=UTC ARGS="--rerun-failed --output-on-failure" make test
}
package_nextcloud-client() {
pkgdesc='Nextcloud desktop client'
depends=(openssl sqlite qtkeychain-qt5 qt5-svg qt5-websockets xdg-utils libcloudproviders
qt5-graphicaleffects qt5-quickcontrols2)
optdepends=(
'kio: integration with Dolphin'
'nemo-python: integration with Nemo'
'python-nautilus: integration with Nautilus'
'python-caja: integration with Caja'
'nextcloud-client-cloudproviders: cloudproviders support'
)
backup=('etc/Nextcloud/sync-exclude.lst')
cd $pkgbase/build
make DESTDIR="$pkgdir" install
rm -v "$pkgdir"/usr/share/cloud-providers/com.nextcloudgmbh.Nextcloud.ini
rm -v "$pkgdir"/usr/share/dbus-1/services/com.nextcloudgmbh.Nextcloud.service
cd "$pkgdir"/usr/share && rmdir -p cloud-providers dbus-1/services
}
package_nextcloud-client-cloudproviders() {
pkgdesc='cloudproviders support for the Nextcloud desktop client'
depends=(nextcloud-client)
cd $pkgbase/build
make -C shell_integration/libcloudproviders DESTDIR="$pkgdir" install
}
Loading…
Cancel
Save